Find an item Search Box has disappeared in a SharePoint 2013 Web Part

This one was a little frustrating and not altogether obvious, so I thought I’d share the result.

Display Search Box nowhere to be found in a SharePoint 2013 Web Part

What

SharePoint 2013 has an amazing inline search feature for lists and libraries. I love it and it won’t be long before it is the one thing folks without 2013 moan about… The idea of being able to search within a list or library and not be taken away to a search page but rather show the results, inline with your columns (metadata) is awesomesauce.

It looks like this…

image

And it is enabled by this…

image

So What

The problem is, if you have migrated existing libraries with customizations or you have played with views in new SharePoint 2013 libraries, you might have changed the “style” from Default, to something like “Shaded” or one of the other styles (I often chose Shaded to help my users with readability).

image

As such, if the view is anything but Default, you won’t find this option “Display Search Box” under “Miscellaneous” in your web part (er, app part now…). It will be missing.

image

 

Now What

Pretty simple really as I’ve already given the clue up above:”

  • When creating views and you want to display the Search Box, stick with the “Default” Style for your view
  • Or if you have a library you have migrated into SharePoint 2013 that was using anything but “Default”, put it back and you will be good to go

 

image

 

Article from: http://itgroove.net/brainlitter/2012/12/31/display-search-box-nowhere-to-be-found-in-a-sharepoint-2013-web-part/